Home>Discussions>INSULATION & HVAC>Unico Air Conditioning not functioning properly---need help!!
8 posts / 0 new
Last post
pistolpete
Unico Air Conditioning not functioning properly---need help!!

I wanted to write to let people know the details of an issue I discovered with my AC a few days back in hopes of getting a solution...I was getting it ready for the summer season and found it is not working properly. I wanted to write all the details here so maybe someone could remedy it?....

It seems all systems work but they're not syncronized?....air handler blower motor runs, outside unit - compressor runs and condensing unit fan runs...

So I immediately went to the air handler due to the foam issue I had fixed last time....and sure enough half the foam had come unglued again....I affixed them again and added metal holders to prevent further dislodging....

When I turned the system on the compressor came on but the air handler blower did not....here is what I found about the different thermostat settings

System switch setting--Fan switch setting--Results
COOL--ON--outside condensing unit on but air handler blower off (blower should be constant on in this fan setting)
COOL--AUTO--outside condensing unit on but air handler blower off
AUTO--ON--air handler blower off outside condensing unit on..blower should be constant on here
AUTO--AUTO--air handler blower off.... outside condensing unit on
OFF--ON--blower off and outside condensing unit off...again blower should be constant on here
OFF--AUTO--blower on and outside condensing unit off...blower should only come on when call for cooling

with SYSTEM- OFF and FAN- AUTO the blower was on and I moved temp to 45deg to call for cooling....after the "comp delay" compressor turned on and air handler blower turned off.....compressor should not even turn on with SYSTEM on OFF should it?

I was getting a blinking error code #3 on LSOM (Lennox System operating monitor) the indicator lights in the condensing unit outside.....so it seems to be maybe an electrical issue??? that systems are not in sync......I thought it might be the thermostat but I temporarily switched that out with a honeywell and got the similar results...

info
Unico 2430 Air handler
Outside condensing unit- Lennox 12SEER (HS-26)

dj1
Re: Unico Air Conditioning not functioning properly---need help!!

You need a HVAC contractor(s) to come and repair it. It's most likely something you can't do.

pistolpete
Re: Unico Air Conditioning not functioning properly---need help!!

The system is essentially a thermostat, 3 relays in the air handler and a switch in the outside compressor.....how hard can it be???....so its most likely a failure of one of these....I'll just start switching out each one for a new one to find the problem.....just thought someone might have encountered the same problem in the past and was aware of the problem/solution.

JLMCDANIEL
Re: Unico Air Conditioning not functioning properly---need help!!

It sounds like a thermostat problem. If it id digital try disconnecting the 24 VAC to the thermostat and reconnecting to see if it resets it so it will work.

Jack

pistolpete
Re: Unico Air Conditioning not functioning properly---need help!!

if you'll note my last paragraph I tried that....I even replaced the thermostat with a new one and got similar results.

dj1
Re: Unico Air Conditioning not functioning properly---need help!!
pistolpete wrote:

The system is essentially a thermostat, 3 relays in the air handler and a switch in the outside compressor.....how hard can it be???....so its most likely a failure of one of these....I'll just start switching out each one for a new one to find the problem.....just thought someone might have encountered the same problem in the past and was aware of the problem/solution.

If you try to replace part by part, you may be able to solve your problem...or not. It could be cheaper than having an A/C tech do it, but then again it may not, if all you do is guess. Hope there is an A/C part supplier near by.
BTW, electrical parts are non-returnable, for obvious reasons.

pistolpete
Re: Unico Air Conditioning not functioning properly---need help!!

Well my 3 relays arrived in the mail yesterday and I proceeded up to the sweltering attic to perform my swaps to try and get relief from this 21day ordeal of heat and humidity

My goal was to replace the relays one at a time to try and figure out which one(s) were bad

I first attempted to replace the "delatching relay" and obtained the same disaapointing results as stated in my opening post.

I then replaced the "lo relay" and low and behold the air conditioner began to work flawlessly!!!! All thermostat functions returned to normal and fan only came on when calling for cooling, fan ran continuously when in the "fan" position, fan didn't kick off when compressor started...

So long story short it was the "lo relay" that had gone bad.

Simple solution that only cost me $18!!! ($6/relay)....so now I have two relays as spares.

BTW for those with a Unico unit the relays are a White-Rodgers 90-380 (184-919) six pin relay.
relay designations stated here are as they are printed on the electrical schematic...there are only 3 relays- HI RELAY, LO RELAY and UNLATCHING RELAY.

As I mentioned this is a very simple system with very few parts....3 relays, transformer and variable speed knob in the air handler....a switch, capacitor in the outside compressor unit.

I'm really satisfied I could fix it myself....this is whats wrong with America today...people are so quick to give up and call someone in instead of trying to understand things and perform simple tests to deduce the problem....not always feasible but in this case very doable for a DIYer with a little knowledge.

Hope this post helps save Unico owners in the future from enduring days of unrelenting heat like myself and saves them hundreds of $$$ on a repairman's visit.

dj1
Re: Unico Air Conditioning not functioning properly---need help!!
pistolpete wrote:

Well my 3 relays arrived in the mail yesterday and I proceeded up to the sweltering attic to perform my swaps to try and get relief from this 21day ordeal of heat and humidity

My goal was to replace the relays one at a time to try and figure out which one(s) were bad

I first attempted to replace the "delatching relay" and obtained the same disaapointing results as stated in my opening post.

I then replaced the "lo relay" and low and behold the air conditioner began to work flawlessly!!!! All thermostat functions returned to normal and fan only came on when calling for cooling, fan ran continuously when in the "fan" position, fan didn't kick off when compressor started...

So long story short it was the "lo relay" that had gone bad.

Simple solution that only cost me $18!!! ($6/relay)....so now I have two relays as spares.

BTW for those with a Unico unit the relays are a White-Rodgers 90-380 (184-919) six pin relay.
relay designations stated here are as they are printed on the electrical schematic...there are only 3 relays- HI RELAY, LO RELAY and UNLATCHING RELAY.

As I mentioned this is a very simple system with very few parts....3 relays, transformer and variable speed knob in the air handler....a switch, capacitor in the outside compressor unit.

I'm really satisfied I could fix it myself....this is whats wrong with America today...people are so quick to give up and call someone in instead of trying to understand things and perform simple tests to deduce the problem....not always feasible but in this case very doable for a DIYer with a little knowledge.

Hope this post helps save Unico owners in the future from enduring days of unrelenting heat like myself and saves them hundreds of $$$ on a repairman's visit.

That's really great! I was the first one to suggest calling a tech, because of many reasons, including, but not limited to: not knowing your skill level and assuming that you wanted a quick fix in this oppressive heat.

Sponsored Stories

TV Listings

Find TV listings for This Old House and Ask This Old House in your area.