6 posts / 0 new
Last post
RJN
GE Stove hood

I have a GE stove hood with exhaust fans and 4 lites. The fans work great for taking the smoke from cooking out and up. My issue is that all 4 lites went out.

I don't think it is anything with power since the blowers run off the same source. I am thinking that over the years grease has built up in the lite sockets preventing proper contact with the bulbs.

Does this sounds reasonable or has anyone experienced this before? Looking for something to clean the lite sockets.

Thanks
RJN :)

A. Spruce
Re: GE Stove hood

First, test each socket with a bulb that is known to work, if it's still no joy, then it is possible that it's dirty sockets, but more likely a bad wire connection at or near the switch. It is possibly even a faulty switch. If you are not familiar with wiring, I'd leave this job to someone more experienced. If you've got some basic wiring and handy skills, then dig in and see what you find.

If you clean the sockets, make sure to turn off the breaker that powers the hood, never trust that the switch is functioning or you could be in for a very rude surprise!

RJN
Re: GE Stove hood

Thanks A. Spruce! I have been round & round with the bulbs. Ones that work in one socket will not work in another and then not work in their original location and eventually all do not work now.

I would like to try something before spending $$ to have someone come in. I think I'll take your advise to shut breaker and try a de-greaser first. I don't mind supporting the economy...... when I have too - lol

Thanks Again :)

A. Spruce
Re: GE Stove hood

It is possible that the sockets are faulty/worn out. Cleaning won't hurt them, but do not use a degreaser, solvent, or any other flammable product. Turn off the breaker, then use a damp sponge only, no soap, no cleaners, if there are any crusties in there, the damp sponge will remove them well enough. Allow the sockets to fully dry before reinstalling the bulbs.

While the bulbs are out, in the bottom of the socket you'll usually find a springy tang. Use a pair of needle nose pliers and lift up on that tang gently and slightly to add a little more spring pressure for better contact with the bulb.

Reinstall the bulbs, turn on the power, and see where you're at.

Another test you can do is to turn the lights on and wiggle the bulbs gently. If they flicker, then you've got contact problems, either with the tang in the bottom of the socket or with loose wiring. Listen for a sizzling sound while wiggling, which is the sign of electrical arcing and bad wire connections.

RJN
Re: GE Stove hood

Alright, thanks for the great advise. I will run thru this and post in a day or two.

Thank You!

A. Spruce
Re: GE Stove hood

Any time. :cool:

TV Listings

Find TV listings for This Old House and Ask This Old House in your area.